PHP

laravel集成swool

php laravel 集成swool

1.安装laravel

composer create-project --prefer-dist laravel/laravel blog 5.5.*

2.安装swool

composer require swooletw/laravel-swoole

3.这个包依赖于 Swoole 。在使用这个包之前,请确保你的机器安装了正确的 Swoole 。使用下面的命令快速安装(linux):

pecl install swoole

4.在安装这个扩展之后,你需要编辑 php.ini 添加  extension=swoole.so

php -i | grep php.ini                      # check the php.ini file location
sudo echo "extension=swoole.so" > php.ini  # add the extension=swoole.so to the end of php.ini
php -m | grep swoole

5.然后,添加服务提供者:如果你使用 Laravel ,在 config/app.php 服务提供者数组添加该服务提供者:

[
    'providers' => [
        SwooleTW\Http\LaravelServiceProvider::class,
    ],
]

6.现在,你可以执行以下的命令来启动 Swoole HTTP 服务。

 php artisan swoole:http start
(0)
分享:

本文由:xiaoshu168 作者:xiaoshu发表,转载请注明来源!

标签:

相关阅读